Incidente
No Approvo, não é possível incluir um aprovador com nível diferente do existente.
Causa
Este incidente ocorre, pois a regra está ativa e somente é possível incluir aprovadores de nível diferente caso a regra esteja inativa.
Solução
Para inativar a regra é necessário que não existam movimentos pendentes de aprovação nessa regra para manter a integridade do sistema temos duas opções. Sendo assim para inserir aprovadores com níveis diferentes, realize os passos a seguir:
Opção 1:
1. No Approvo, realize a aprovação de todos os movimentos pendentes nessa Regra;
2. Inativar a regra necessária;
3. Incluir os aprovadores nos níveis diferentes;
4. Ativar a regra.
Opção 2:
Atenção! Esse procedimento deve ser realizado com atenção, pois qualquer alteração realizada de forma indevida irá comprometer toda a estrutura de aprovação da empresa, podendo aprovar movimentos automaticamente de forma incorreta e não temos como reverter, caso necessário acionar nossa equipe de consultoria para acompanhamento.
Observação: A partir das versões 5.02.01.28 e 5.00.00.97 foi implementada uma nova funcionalidade que poderá ser utilizada para que não ocorra a aprovação automática de documentos sem que o administrador do Approvo esteja ciente.
1. No Approvo, acesse o menu lateral e clique em Configuração / Perfil de Alçada;
2. Selecione o Perfil necessário, clique nos 3 pontos e depois em Vigências;
3. Selecione a ultima vigência ativa, e clique na opção Copiar:
- A data de inicio da vigência será a data em que estiver copiando;
- A vigência será clonada com todas as regras e com a vigência inativa.
4. Clique em Regras, inative as regras necessárias para conseguir incluir aprovadores com níveis diferentes;
5. Após concluir toda parametrização das novas regras, volte para vigência, clique em Editar e Ative a vigência.
Veja também: Approvo - Como cadastrar novos aprovadores e reclassificar a ordem de aprovação
Observação: Ao realizar essa opção, estamos clonando a vigência criando uma nova com novas regras, ao ativar a vigência será realizado a migração dos documentos que estão em aprovação no ERP, e caso não encontre nenhuma regra nessa nova vigência, ele será aprovado automaticamente. Ao ativar a nova vigência os movimentos que estão na vigência antiga serão migrados para a nova vigência caso exista a mesma regra, e todo processo de aprovação será reiniciado, necessitando novamente de aprovações de níveis anteriores. A vigência antiga ficará ativa caso até que os movimentos sejam aprovados, mas ela não irá mais receber aprovações, todas os novos movimentos entrarão na nova vigência.
Depois de realizar os passos sugeridos na opção 2, não ocorrerão migrações de documentos do Mega e isso só ocorre quando existe alteração das filiais vinculadas ao perfil, uma vez que estamos tratando da inclusão de vigência em um perfil já cadastrado e configurado, com isso as migrações das devidas filiais já ocorreram previamente.
Neste caso, o que pode ocorrer de migração de documentos é se o usuário inativar a vigência anterior depois de ativar a nova vigência, neste cenário temos a migração dos documentos da vigência anterior para a nova, com a possibilidade de documentos serem aprovados automaticamente caso alguma alteração tenha sido realizada de forma que a cobertura das regras da nova vigência não atendam aos documentos que estavam na vigência anterior que foi desativada.
Entretanto, destacamos que o Approvo permite que novas vigências sejam cadastradas e ativadas sem a necessidade de desativar as vigências anteriores, permitindo que os documentos que já estavam em aprovação naqueles fluxos, sigam os processos de aprovação previamente cadastrados.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.
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